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Generate, Print, or Export state diagrams

You can generate the state diagram for a machine by selecting "Show State Diagram" in the context 
menu of a machine node, main machine or sub machine, ("AlarmSystem" in the example below) or by 
selecting the "Tools->Generate State Diagram" menu item when an SBS tab is opened in the Model 
Editor. 

Show State Diagram

Note: 

●     The state diagram for the selected machine is shown in the "State Diagram" viewer.

●     The "Show State Diagram" and "Export State Diagram" apply to the selected machine.

●     The state diagram might become unreadable for large ASD models due to overlapping texts. Try 
to use smaller fonts.

●     The following navigation options are available in the "State Diagram" viewer to improve 
readability of the generated state diagram: zooming, scrolling, and panning: 

�❍     Press Ctrl+mouse wheel for zooming in and out
�❍     Press Shift+mouse wheel for shifting horizontally
�❍     Scroll with the mouse wheel to shift vertically
�❍     Press Ctrl++ and Ctrl+- to Zoom in and Zoom out in the state diagram

The following figure shows the state diagram for the Alarm system:

 

The state diagram of the Alarm system

Note: Synchronous return states are displayed as a diamond.

The ASD:Suite enables you to specify several configuration settings for state diagram viewing. 

The following list shows the options which are available as configuration settings, via the State 
Diagram viewer's toolbar, for state diagram viewing: 

●     Fit to available window height

●     Fit to available window width

●     Fit to available window size

●     Show or hide all self-transitions;

●     Show or hide all floating states;
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Print ASD models

The information contained in a tab shown in the Model Editor can be printed if you select the "File-
>Print..." menu item or if you press the Ctrl+P key combination.

Note: Before you print data of the ASD model ensure that the settings for the printing conform to 
your expectations. You have to select the "File->Page Setup..." menu item to obtain the "Page Setup" 
dialog. This dialog is used to view and specify the configuration options for printing, i.e. the paper 
format on which the data is going to be printed, the orientation of the chosen paper and the desired 
margins.

The following figure shows an example of the "Page Setup" dialog:

The Page Setup dialog

Note: 

●     The defaults for the Margins section depend on the active printer.

●     The unit of measurement (like, inches or millimetres) depends on locale settings of the 
computer.

The following figure shows the "Print" dialog obtained when you selected the "File->Print..." menu 
item or pressed the Ctrl+P key combination:

The Print dialog

Note: 

●     If the active tab is a multi-table tab, i.e. an interface declaration tab (like, Application Interfaces, 
Notification Interfaces, Modelling Interfaces or Transfer Interface), a "States" tab, or a "State 
Variables" tab, all data specified in the tables of the respective tab is sent to the printer. 

●     If the active tab is an SBS tab, the used filters determine the data which is sent to the printer, i.
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Specify state invariants

The ASD:Suite enables specification of preconditions which must hold when the modelled component 
enters in a specified state. These preconditions are called state invariants. The state invariants are 
used as a global safe guard for all the behaviour which can happen in a state of a component, i.e. all 
behaviour in the respective state is possible only if the specified state invariant holds. 

The ASD:Suite ensures that in each state of an SBS there is a rule case which defines this state 
invariant. It will be the first rule case of the state and it has "Invariant" as trigger. This rule case can be 
hidden or made visible using the "Filters->Hide Invariants" menu item.

You have to specify the precondition, i.e. the state invariant, in the "Guard" column of the respective 
rule case. During model verification if the state invariant does not hold a state invariant violation will 
be raised.

Note: There shall be only one rule case with "Invariant" as trigger in each state.

 

Example of an Invariant rule case

ASD:Suite User Manual

ASD:Suite Release 3 v8.1.0

TABLE OF CONTENTS

●     The ASD:Suite software design platform 
●     ASD Concepts 

�❍     Components
�❍     Models
�❍     Sequence Based Specifications
�❍     The ASD:Triangle and Correctness
�❍     Operational semantics 

■     Operational semantics of rule 
cases

■     Client requests
■     Notification interfaces
■     ASD Timers and the Timer 

Cancel Guarantee
�❍     State types in a design model

●     The User Interface 
�❍     Tabs, Panes and "dockable" 

Windows 
■     Panes and "dockable" windows
■     The Start Page
■     The "Model Explorer" in detail
■     Meaning of colours in the SBS 

tab
■     The context information field in 

the SBS tab
�❍     Menus 

■     File
■     Edit
■     View
■     Filters
■     Verification
■     Tools
■     Help

�❍     Toolbars 
■     The main toolbar
■     The "debugging" toolbar
■     The state diagram viewer 

toolbar
�❍     Status bar

●     Basic Modelling 
�❍     Build ASD components
�❍     Create ASD models 

■     Create interface models
■     Create application interfaces
■     Specify events for application 

interfaces
■     Create notification interfaces
■     Specify events for notification 

interfaces
■     Create modelling interfaces
■     Specify events for modelling 

interfaces
■     Create design models

�❍     Create Tags
�❍     Specify used services 

■     Specify primary references
■     Specify used interfaces
■     Specify secondary references
■     Remove references

�❍     Specify behaviour 
■     Specify state variables
■     Specify state information
■     Specify actions
■     Specify target state
■     Specify comments
■     Specify tags
■     Specify guards
■     Specify state variable updates
■     Specify non-deterministic 

behaviour
■     Add or delete a rule case
■     Insert or replace rule cases
■     Duplicate a state

�❍     Define and use parameters 
■     Parameter declaration
■     Example of (simple) parameter 

passing 
■     Changing the number of 

parameters
■     Renaming the parameter in the 

trigger of a rule case
■     Specifying arguments for an 

action
■     Parameter storage

�❍     Load and close ASD models
�❍     Upgrade ASD models

http://community.verum.com/documentation/user_m....aspx/8.1.0/advanced_modelling/state_invariants (1 of 2) [06/02/2012 09:20:20]







ASD:Suite User Manual 

Operator Description Guard example Actions example State Variable 
Updates example

# cardinality i==#S - i=#S

<> empty reference S==<> - S=<>

== equality operator S1==S2 - b=(S1==S2)

!= inequality operator S1!=S2 - b=(S1!=S2)

= assignment - - S=S1

+ concatenation S==S1+S2 - S=S1+S2

head head S==head(S1) head(robots):IRobot.Start() S=head(S1)

tail tail S==tail(S1) tail(robots):IRobot.Start() S=tail(S1)

[] indexing S==S1[2] robots[2]:IRobot:Start() S=S1[2]

in subset S1 in S2 - b=S1 in S2

that that S[3]==that that:IRobot.Start() S=that

Note: S, S1 and S2 are all used service reference state variables; variable i is an integer state 
variable; variable b is a boolean state variable.

The following list presents two examples of using used service reference state operators in the SBS of 
a design model: 

1.  Iterate over a number of sensors to activate them one by one: 

 

Iterate over a used service reference state variable member by member

 
Note: 

�❍     "activate" is a used service reference state variable for all the to-be-activated sensors 
defined for the model. Its initial value is all the sensors, i.e. all door and window sensors: 
DoorSensor+WindowSensor

�❍     "deactivate" is a used service reference state variable for all the sensors to be 
deactivated. Its initial value is the empty sequence "<>".

2.  Deactivate all sensors and wait for the result of deactivation for each sensor respectively: 

 

Perform an action on all members of a used service reference variable and wait for all of them 
to respond

 
Note: 

�❍     "deactivate" is a used service reference state variable for all the sensors to be deactivated.
�❍     "deactivated" is a used service reference state variable for all the sensors which are 

deactivated.
�❍     The "deactivate in deactivated + that" guard evaluates to true if all members of 

"deactivate" are present in "deactivated + that". "deactivated + that" translates to the 
"deactivated" sequence together with the current service instance

The following table presents the way in which the constructions introduced above (primary/
secondary references, used service reference operators, or used service reference state variables) can 
be used when adding actions:

Syntax Description

myReference:IMyAPI.Start() call Start on every service instance in myReference

myReference[3]:IMyAPI.Start() call Start on the third service instance in myReference

that:IMyAPI.Start() call Start on the service instance that generated the trigger

head(myReference): IMyAPI.Start() call Start on first service instance in myReference

tail(myReference): IMyAPI.Start() call Start on every service instance in myReference, except the 
first one

where myReference denotes a primary reference, a secondary reference or a used service reference 
state variable.

Note: 

●     The used service reference of a valued action must always be a singleton, i.e. a reference of 
length 1.

●     The used service reference of a void action must contain at least one element.
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Specify construction parameters

Component instantiation - main concepts and default behaviour
From every interface model, an interface is generated in code. From every design model, a component 
is generated which implements its interface. Of this component, you can construct one or more 
instances at run-time. Also, you can define that an ASD component constructs instances of other 
components: you do this by defining primary service references.

Each primary reference defines the service (interface) that it expects, and also the component to 
instantiate to implement the interface. The latter is specified in the "Construction" field.

models, components, instances

For instance, consider the picture above. In the leftmost column, we have an Alarm.dm design model 
which implements the Alarm.im interface model. In turn, it has a primary reference which refers to 
the Sensor.im model. This primary reference has "WindowSensor" in its Construction field, indicating 
that it should construct an instance of a component called "WindowSensor" at construction-time.

The second column depicts the compile-time situation: presumably, there is hand-written code all 
around the generated ASD code: a GUI, which uses the Alarm component, and a hand-written Sensor 
implementation which is called "WindowSensor".

Finally, in the third column, we get to the situation at construction-time: when the application is 
started, the GUI constructs an instance of the Alarm component, which in turn creates an instance of 
the WindowSensor component.

Every generated component has a static method called GetInstance() (or, in some languages, 
_getInstance(), or getInstance()). Every hand-written used component must have one too. This 
GetInstance() method is used to create instances of the component. So, at run-time, the GUI actually 
calls AlarmSystemComponent::GetInstance() to get a new instance, which in turn calls 
WindowSensorComponent::GetInstance().

For more details see information about component instantiation/integration in C++, C#, Java, C, or 
TinyC

Instance construction - alternatives
There are various ways to influence how component instances are created.

Firstly, you can pass parameters to a component instance at construction time. Within an ASD 
component, you can pass these construction parameters along to used components. Examples are in 
Passing parameters to a component at construction time.

Second, for ASD components, you can set the Component Type to "Singleton" or "Multiple" (for 
details see Specify component type). Setting the Component Type to "Singleton" has the effect that 
only one instance is ever created. Setting the Component Type to "Multiple" causes a new instance to 
be created for every use.

But what if you want two ASD components to share an instance, without using a Singleton 
component? Or what if you want to determine the class used for a hand-written component at 
construction time? Instead of letting the parent ASD component construct an instance, you can also 
pass a used component instance to an ASD component as a parameter. This way, you have full control 
over how many instances of which type are constructed, and where they are used. Examples are in 
Passing an instance of a used component at construction time, Passing a vector of instances at 
construction time, Pass a shared instance at construction time, or in Pass a primary reference at 
construction time.
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Passing an instance of a used component at construction time

Instead of letting a component construct its own used instances, you can also pass instances to it at 
construction time.

For this to work, the component must define a special type of construction parameter, and then use 
this construction parameter in the primary reference.

 

Passing a used component instance at construction time

First, we define the construction parameter in the AlarmSystem design model. Go to the Model 
Properties, click Code Generation, and make sure the "Interface" radio button is checked. 

Construction parameter for a used service

This time, we use the special syntax "service(modelname)" for the parameter type. The model name 
must match the interface model name of the primary reference - in this case, "Sensor" (i.e. NOT the 
file name!), see also the "Service" field in the next figure. Now, the AlarmSystem component requires 
a parameter at construction time. This parameter must be filled in with an instance of a component 
that implements the Sensor interface. The exact effect of this in your code is described in component 
instantiation/integration in C++, C#, Java, C, or TinyC.

What we still have to do, is make use of this parameter for the WindowSensor primary reference:

 

Using a construction parameter for a used instance

We have used the special syntax "use parametername" to denote that instead of constructing a new 
instance, the AlarmSystem component should use the construction parameter called "someSensor" 
that was defined in the model properties.
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Pass a primary reference at construction time

Suppose there is an ASD component on top of the Alarm and the Monitor. This component can have a 
primary reference to Sensor.im as well. It can pass this primary reference to its other used 
components.

Defining an instance to pass along within ASD

In the top-level component, we define a primary reference to Sensor, but we make the Used 
Interfaces field empty. We can now pass the mySensor primary reference as a construction argument 
to the other primary references: 

 

Passing along a primary reference

This way, you can defer the decision of what instance to construct to a higher-level ASD component 
without any hand-written code. Effectively, the three lines of code in the previous example are now 
reduced to just one:

myGuiInstance = GuiComponent::GetInstance();
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Create an ASD model from an existing one

The ASD:Suite enables you to create a new model using an existing model. For example, this allows 
you to make a copy of a model with the intention to modify it, and use it in the same system. In 
contrast, this will not be possible if you create an exact copy of the model. For details about creating 
an exact copy see "Save As". 

Note: Creating a copy of an ASD model is introduced to prevent errors/conflicts by manually copy/
paste a model in your file-system, i.e. create an exact copy of the model, and use it in the same 
system as the source model. 

Create an ASD model of the same type as the currently opened one
The following list contains the steps to create a new ASD model of the same type as the currently 
opened ASD model: 
1.  Open an ASD model.

2.  Press Ctrl+N or Select the "File->New..." menu item

3.  Specify a Model name and a File name for the new model

4.  Select the "Copy from active model (<current_model_name>)" item under "Options:"

5.  Press OK if you want to create the copy or Cancel if you want to stop without creating a copy

The following figure shows the "New Model" dialog with the option to create a copy of the selected 
IAlarmSystem interface model:

 

The New Model dialog to create a copy of the currently opened ASD model

Create an ASD model as a copy of an ASD model stored on disk
The following list contains the steps to create a new ASD model as a copy of an existing ASD model 
stored on the disk: 
1.  Start the ASD:Suite.

2.  Press Ctrl+N or Select the "File->New..." menu item

3.  Specify a Model name and a File name for the new model

4.  Select the "Copy from model on disk" item under "Options:"

5.  Select the file to be copied

6.  Press OK if you want to create the copy or Cancel if you want to stop without creating a copy

The following figure shows the "New Model" dialog with the option to create a copy of the specified 
interface model:

 

The New Model dialog to create a copy of a non-currently-opened ASD model
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Specify publishers and observers

In ASD by default notifications manifest themselves as a point to point communication between the 
ASD component and the used service where the notification interface was defined.

In case you want a component to broadcast events defined on a notification interface to more than 
one observer (client component using your ASD component) you have to define the respective 
notification interface as a broadcasting interface by check-marking the "Broadcast" check-box for the 
defined notification interface. The following figure shows an ISensor_CB notification interface defined 
as a broadcasting interface.

 

A notification interface flagged as broadcasting

In case you specify in a design model a broadcasting notification interface as a used interface you 
have the possibility of specifying which events on the respective notification interface you are going 
to observe. 

Note: In case the respective notification interface is newly created and specified as used interface 
for the first time, its events will not be visible in the SBS of the design model. This is caused by the 
fact that the events are flagged as non observed by default. If you want to observe any event from 
the respective interface you have to flag the respective event as observed.

The following figure shows the situation in which you are interested only in Deactivated() notifications:

Setting notification events as observed or not

Note: 
●     IMPORTANT: Since initially the broadcasting interfaces are unsubscribed you have to explicitly 

subscribe to all used instances of notification interfaces which are flagged as broadcasting. For 
example, you have to specify Subscribe(sensor:ISensorCB) if the used service instance name is 
"sensor" and the broadcasting notification interface is "ISensorCB." 

●     You are able to subscribe, respectively unsubscribe at any moment by using the two actions 
Subscribe and, respectively Unsubscribe. The Unsubscribed status is reported by an 
"asd_Unsubscribed" event. Therefore, you will have to specify behaviour for the respective 
event in all places where it can occur. The unsubscribed status means that the unsubscribe 
request is processed and that there will be no more notification events on the unsubscribed 
interface in the queue after the asd_Unsubscribed event. See following figures for an example: 

�❍     Subscribe to "WindowSensor:ISensor_CB" instance of the ISensor_CB broadcasting interface 
defined in the WindowSensor used service: 
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The Select Actions dialog showing the selection of the Subscribe action

 

Data in the SBS tab showing the use of the Subscribe action

�❍     Unsubscribe from the "WindowSensor:ISensor_CB" instance of the ISensor_CB broadcasting 
interface defined in the WindowSensor used service: 

The Select Actions dialog showing the selection of the Unsubscribe action
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Data in the SBS tab showing the handling of the "asd_Unsubscribed" event

●     In case you call Subscribe on an instance of a broadcasting notification interface more than once 
before unsubscribing only the first request is considered.

●     In case you call an Unsubscribe on an instance of a broadcasting interface more than once 
before the asd_Unscribed event occurs the request will be ignored and no asd_Unscribed event 
will be raised.

●     In case you call an Unsubscribe on an instance of a broadcasting interface more than once after 
the asd_Unscribed event occurred but before subscribing again, or when you are not 
subscribed, the asd_Unsubscribed event will be raised for every Unsubscribe request.

●     In case you specify one event as not observed, the event will not appear as trigger in the SBS 
tab for your design, i.e. you will not have to specify a (set of) rule case(s) for the respective 
event.

●     Since the choice of observing a large set of events from the publishers you subscribed to, and 
the (sometime) large number of the respective events might cause a saturation of the queue, it 
might be useful to define one or more of the respective events as Singleton Event. For details 
see "Use singleton events to restrict notification events".
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Serialise ASD components

Serialisation is a mechanism available in Java to store a Java object in a persistent form on disk, for 
example, to send over the network or for use in Remote Method Invocation.

In ASD, the serialisation is achieved via implementing Externalizable interface, wherein two methods 
are introduced: writeExternal and readExternal. These methods are visible in the Java generated code 
for the design model.

The reason to use the Externalisable over the Serialisable interface, is that Externalisable provides 
complete control to the user on the marshalling and un-marshalling process, however with the 
drawback of reduced flexibility. With regards to versioning of Serialisable objects, only the top level 
component is versioned.

In order to ensure serialisation you have to select the Serialisable check-box in the Model Properties 
dialog window under the "Code Generation->Java" tab. The following figure shows the Serialisable 
check-box in the interface model for the Sensor service:

 

The Serialisable check-box
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Check conflicts

The following types of conflicts might occur while building ASD models with the ASD:Suite: 

●     Reconcile conflicts - They occur when you load a design model in the ASD:Suite and one or 
more of the related interface model(s) can not be located, contain(s) specification conflicts or 
the design model refers to events or interfaces which are not declared in the related interface 
models. The missing item in the design model is indicated by the "<<<", and ">>>" brackets 
around it.

●     Specification conflicts - They occur when you specify behaviour which violates the ASD model 
specification rules.

These are the alternatives for checking for conflicts in your ASD model: 

●     Press F8, or

●     Select the "Tools->Check Conflicts" menu item.

The conflicts are shown in the "Conflicts" window. To identify the cause of a conflict you can double-
click the conflict message to jump to its location. 

Note: When jumping to a filtered-out rule case, that single rule case will be unhidden. You can hide 
the respective rule case again, by (re-)applying the filter(s). See "Selection and application of filters" 
for more details about applying filters. 

The following figure shows an ASD model with conflicts:

 

Note: Each conflict has an associated error code. Please report that code if you have difficulties in 
fixing the conflict(s). Clicking with the mouse on the error code will open a webpage in your default 
browser with some guidelines to fix the conflict.
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Fix reconcile conflicts

The following table shows the messages associated to "reconcile conflicts" that are identified by the 
ASD:Suite when a design model is loaded:

Note: During the lifetime of a "reconcile conflict" you are only allowed to perform changes in the 
interface declarations (the "Application Interfaces", "Notification Interfaces", "Used Services" and 
"Used Notification Interfaces") tabs or you can add missing models in the "Model Explorer" window 
and re-establish service dependencies.

Error code Explanation Fix

RC1 The conflict occurs if the design model 
refers to an implemented or used service 
defined in an interface model which can 
not be located.

●     Solution1: 
�❍     Select the "Models" group in the 

"Model Explorer", right-click and 
select the "Add Model" item in 
the context menu.

�❍     Locate and select the missing 
interface model.  
Note: These steps must be 
repeated for all missing interface 
models

�❍     Select the design model in the 
"Model Explorer" and then select 
the "Tools->Reconcile" menu 
item. After this the reconcile 
conflict is fixed.

�❍     Save the design model.

●     Solution2: reassign interface model 
dependencies by changing the 
dependency to the missing interface 
model such that the new location is 
considered. For more details see 
"Reassign interface model 
dependencies in a design model".

RC2 The conflict occurs if the design model 
refers to an interface which is not defined 
anymore in the same interface model as it 
was when the design model was last time 
saved. 

●     Solution 1: change interface model: 
make sure that all the interfaces 
referenced in the design model are 
defined in at least one of the 
referenced interface models.

●     Solution 2: rename missing interface 
in the design model to an existing yet 
unused interface in one of the 
referenced interface models 

�❍     Locate the missing interface 
under the "Implemented Client 
Interfaces" group of the design 
model in the "Model Explorer", or 
as an interface in the "Used 
Interfaces" column in the 
"Primary References" sub-tab of 
the "Used Services" tab.

�❍     Rename the interface (by double-
clicking on the name or pressing 
F2 when the interface is selected) 
to an existing but unused 
interface in the referenced 
interface model.

�❍     Select the design model in the 
"Model Explorer" and then select 
the "Tools->Reconcile" menu 
item. After this, the reconcile 
conflict is fixed.

�❍     Save the design model.

●     Solution 3: delete missing interface in 
the design model: 

�❍     Locate the missing interface 
under the "Implemented Client 
Interfaces" group of the design 
model in the "Model Explorer", or 
as an interface in the "Used 
Interfaces" column in the Primary 
References sub-tab of the "Used 
Services" tab.

�❍     Remove the interface by selecting 
the "Delete Application Interface" 
or "Delete Notification Interface" 
in the context menu obtained 
when pressing the right mouse 
button while selecting the 
missing interface.

�❍     Select the design model in the 
"Model Explorer" and then select 
the "Tools->Reconcile" menu 
item. After this the reconcile 
conflict is fixed.

�❍     Save the design model.

●     Solution 4: re-establish link to the 
specified interface. This solution 
should be used in case the specified 
as missing interface still exists in the 
referenced interface models. Usually 
this happens if the interface was 
deleted and recreated or restored. 

�❍     Locate the missing interface 
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under the "Implemented Client 
Interfaces" group of the design 
model in the "Model Explorer", or 
as an interface in the "Used 
Interfaces" column in the Primary 
References sub-tab of the "Used 
Services" tab.

�❍     Delete the "<<<" in front of the 
specified as missing interface.

�❍     Delete the ">>>" after the 
specified as missing interface.

�❍     Select the design model in the 
"Model Explorer" and then select 
the "Tools->Reconcile" menu 
item. After this the reconcile 
conflict is fixed.

�❍     Save the design model.

RC3 The conflict occurs if the design model 
refers to an event or a reply event which 
does not belong to the specified interface.

●     The following list shows the solutions 
to fix this type of reconcile conflicts 
in case the missing event is not the 
"asd_Unsubscribed" event: 

�❍     Solution 1: change interface 
model: one should ensure that all 
referenced events (and/or reply 
events) in the design model are 
defined as events (respectively 
reply events) in the referenced 
interface models.

�❍     Solution 2: rename missing event 
in the interface to an existing yet 
unused event in the respective 
interface 

■     Double click on the error 
message: this opens the 
interface declaration for the 
interface from which the 
referenced event is missing.

■     Rename the event by double-
clicking on the name to an 
existing but not yet used 
event in the respective 
interface.

■     Select the design model in the 
"Model Explorer" and then 
select the "Tools->Reconcile" 
menu item. After this the 
reconcile conflict is fixed.

■     Save the design model.
�❍     Solution 3: delete missing Event 

in the design model: 
■     Double click on the error 

message: this opens the 
interface declaration for the 
interface from which the 
referenced event is missing.

■     Delete the respective event.
■     Select the design model in the 

"Model Explorer" and then 
select the "Tools->Reconcile" 
menu item. After this the 
reconcile conflict is fixed. 

■     Save the design model.
�❍     Solution 4: re-establish link to the 

specified event. This solution 
should be used in case the 
specified as missing event still 
exists in the related interface 
model. Usually this happens if the 
event was deleted and recreated 
or restored. 

■     Double click on the error 
message. This opens the 
interface declaration for the 
interface from which the 
referenced event is missing.

■     Delete the "<<<" in front of 
the specified as missing event.

■     Delete the ">>>" after the 
specified as missing event.

■     Select the design model in the 
"Model Explorer" and then 
select the "Tools->Reconcile" 
menu item. After this the 
reconcile conflict is fixed.

■     Save the design model.

●     The following list shows the steps to 
fix this reconcile conflict if the event 
is the "asd_Unsubscribed" event: 

�❍     Double click on the error 
message. This opens the Used 
Notification Interfaces tab with 
the notification interface from 
which the "asd_Unsubscribed" 
event is missing.

�❍     Delete the respective event.
�❍     Select the design model in the 

"Model Explorer" and then select 
the "Tools->Reconcile" menu 
item. After this the reconcile 
conflict is fixed. 

�❍     Save the design model.

RC4 The conflict occurs when you attempt to 
use the same interface model as 
"implemented service" and as "used 
service".

Create a copy of the interface model and 
use the respective copy as used service.  
Note: Do not make a copy in your file-
system. This will not solve the reconcile 
conflict. You have to create a new model as 
a copy of the interface model causing the 
conflict. For details see "Create an ASD 
model from an existing one". 
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Fix interface related conflicts

The following table shows the specification conflicts related to usage and declaration of interfaces 
when building ASD models:

Error Code Explanation Fix

RC24 Each service should have at least one 
application interface

Specify at least one application interface in 
the interface model of the indicated service

RC25 Each interface must have at least one event Specify at least one event for the respective 
interface

RC26 Each interface which has at least one 
valued event, must have at least one reply 
event

Specify at least one reply event for the 
respective interface or make all events void

RC31 Broadcasting interfaces are not allowed in 
the SingleThreaded execution model.

Turn off the Broadcast flag for the specified 
interface

RC32 There is no value in setting a yoking value 
greater than the queue size of the using 
design model.

Change either the queue size or the yoking 
threshold.

RC33 Yoking is only usable in the Standard 
execution model

Remove the yoking threshold for the 
specified event or use the Standard 
execution model instead of the 
SingleThreaded one.

RC51 There are no events specified as Observed 
for the specified broadcasting interface

Ensure that there is at least one event of 
the mentioned broadcasting interface 
specified as observed, or clear the 
broadcasting flag for the mentioned 
interface

RC52 It is not allowed to flag ITimer notification 
events as Singleton events

Ensure that the specified timer notification 
event is not flagged as Singleton event

RC118 The event queue must be at least of size 1 Ensure in the design model properties that 
the specified size for the event queue is 
greater or equal than 1.
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Fix used service references related conflicts

The following table shows the messages that inform you that there are specification conflicts related 
to services used in a design model:

Error Code Explanation Fix

RC34 There are one or more specification 
conflicts in the specified interface model 

Check and fix conflicts in the interface 
model

RC35 The specified interface model is not open/
loaded

Add the interface model to the design 
model by performing the following steps: 

●     Select Models in the Model Explorer.

●     Select the Add model in the context 
menu after pressing the right mouse 
key.

●     Select the missing interface model 
and press Open.

RC36 The design model name and the 
component name can not be the same. in 
the Construction field of a primary 
reference. This is to ensure that a 
component does not use itself.

Change the design model name, or the 
component name in the Construction field 
of a primary reference.

RC37 There is no used service reference defined 
for the indicated used service

Specify at least one service reference for 
the indicated used service, or remove it as 
a used service.

RC38 The declaration of the indicated primary or 
secondary reference is not valid. This can 
be because: 

●     The name is not valid: Used Service 
Reference names should start with a 
letter, followed by letters, digits and/
or underscores;

●     The name is already in use for 
something else (e.g. a keyword or 
another used service reference).

Ensure that the name of the indicated used 
service reference complies with the rules 
for naming used service references and 
that it is not used for naming any other 
item in your model. 

RC39 The secondary reference does not have any 
primary references.

Specify at least one primary reference for 
the indicated secondary reference or delete 
the secondary reference.

RC41 The ASD:Timer service is specified as a used 
service, while the "ITimer" application 
interface is not specified as a used interface.

Specify the "ITimer" as a used interface, or 
remove the ASD:Timer service as a used 
service.

RC42 The ASD:Timer service is specified as a used 
service, while the "ITimerCB" notification 
interface is not specified as a used interface.

Specify the "ITimerCB" interface as a used 
interface, or remove the ASD:Timer service 
as a used service.

RC43 Not all interfaces defined in the indicated 
SingleThreaded used service are specified 
as used interfaces.

Ensure that all interfaces defined in the 
indicated SingleThreaded used service are 
specified as used interfaces, or remove the 
used service.

RC44 If the implemented service is 
SingleThreaded, all used services must be 
SingleThreaded as well.  
Exceptions: it is allowed to have a Standard 
used service if 

●     The used service does not have 
notification interfaces

●     The used service does not have 
modelling interfaces

●     The primary reference uses all 
interfaces

Ensure that all used services use the 
SingleThreaded execution model or they 
fall in one of the exceptional cases.

RC46 The implementation of the ASD Timer 
requires that the models use the Standard 
execution model. For details see "Specify 
execution model".

Ensure that all used services use the 
Standard execution model, or remove the 
ASD Timer service as a used service.

RC48 At most 128 instances can be put into a 
primary reference.

Lower the instance count that is specified 
in the square brackets behind the reference 
name.

RC49 Each used service reference with 
unspecified size (e.g. v[*]) must have an 
instance count specified in the "#Instances 
in Verification" column.

Fill in the "#Instances in Verification" 
column for the indicated used service 
reference.

RC50 The number of instances for a primary 
reference used in verification should be at 
least 1 and should not exceed the specified 
size of the respective primary reference.

Ensure that the number in the "#Instances 
in Verification" column is greater than 1 
and less than or equal the size of the 
service reference.
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RC133 The primary reference is not used as a 
construction argument to another primary 
reference and it has no used interfaces.

Use the primary reference as a 
construction argument to another primary 
reference, or specify used interfaces for it, 
or remove the primary reference.

RC134 ITimer is not allowed as service type for a 
construction parameter. 

Check your code generator settings and 
remove ITimer as service type of the 
indicated construction parameter.

RC135 The argument to a use construction 
expression must be a construction 
parameter of a service() type declared in 
the code generator settings. It cannot be a 
primary reference, a literal, or a 
construction parameter of a user-defined 
type. 

Ensure that the indicated argument 
complies with the syntactical rules of 
arguments to a use construction expression.

RC136 The primary reference refers to a 
construction parameter of the wrong type.

Ensure that the construction parameter has 
the interface model name of a primary 
reference as type.

RC137 The used instances refered by the specified 
construction arguments depend on each 
other and create a cyclic construction 
dependency.

Remove the cyclic dependency.

RC138 A construction argument can not be of type 
ITimer.

Change type.

RC139 The size of the primary reference does not 
match the size of the specified construction 
parameter.

Ensure that the size of the primary 
reference does match the size of the 
specified construction parameter, or vice 
versa.

RC140 A primary reference to ITimer cannot be 
passed as construction argument.

Change the primary reference, or remove 
the construction argument.

RC141 The secondary reference contains a 
primary reference without used interfaces.

Specify used interface for the primary 
reference, specify a different primary 
reference, or remove the secondary 
reference.
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Verify an ASD model

These are the steps to be followed when you want to verify an ASD model: 

1.  Prepare the model for verification

2.  Start verification

3.  Analyze and fix the reported errors

Note: If one of your checks ends up in "Queue overflow" please see "Use singleton events to 
restrict notification events" and/or "Use yoking threshold to restrict notification events" for 
possible solutions.
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Specify component type

In ASD you can choose between two types of components: Singleton or Multiple. 

When selecting Singleton for a component, a single instance of the respective component will be 
created and this instance will be accessed by all components that use the Singleton component. In 
case of Multiple, each component that uses the respective component will create and use its own 
instance(s) of the Multiple component.

To specify the desired component type you have to open the model properties dialog for your design 
model by selecting the model in the "Model Explorer", right-click and select the "Properties" item in 
the context menu.

The following dialog is shown:

The Properties dialog for a design model
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Define construction parameters

Components can have construction parameters - parameters that are passed to the component when 
it is instantiated. Construction parameters can be regular parameters like integers and strings, or they 
can be service parameters - instances of other components. Regular parameters can be passed on 
further to hand-written components. Service parameters can be used to pass used services to a 
component (this is known as dependency injection).

The construction parameters are defined in the "Construction parameters" field of the code 
generation settings:

Settings for code generation in an ASD design model

 
This is the syntax for construction parameter definition: 

1.  For parameters of user defined types: "[in]name:std::string" 
Note:You can use any type you like that the programming language allows. For most languages, 
you will need to include/import the type using the "Include/import (declaration)" field of the 
code generator settings. The following figure shows the dialog window which facilitates 
specification of target language specific code generator settings: 

2.  For a single injected service: "[in]siren: service(ISiren)"

3.  For a vector of injected services: "[in]sensors: service[](ISensor)"

Note: 

●     When you want to define multiple construction parameters you specify them in a "," separated 
list

●     The border of the "Construction parameters" field is coloured in red if the syntax is incorrect

For more details see "Specify construction parameters".
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Ensure correct referencing of user defined types

When you specified parameters of user defined types in your ASD component you need to ensure 
that the files where you defined the respective types are referenced in the generated code.

The ASD:Suite provides an "Include/import" field in the code generation "Properties" dialog of your 
ASD model to facilitate the specification of the required referencing statements. You can access the 
code generation "Properties" dialog of your model by selecting the ASD model in the "Model 
Explorer", right-click, select the "Properties" in the context menu and choose your target language 
under the "Code Generation".

Note: Any data you fill in the "Include/import" field for any other target language than C, C++ or 
Java is going to be ignored during code generation.

The following figures show the code generation "Properties" dialog for target language C++ in case 
the ASD model is an interface model, or a design model, respectively:

The code generation properties for target language C++ in an interface model

 

The code generation properties for target language C++ in a design model

 
The content of the "Include/import" fields for C and C++ should be zero or more include statements, 
one per line. An include statement is one of the following: 

●     #include "FileName", or

●     #include <FileName>

where, FileName is the name of the header file containing definitions of user defined types. 

For Java the content of the "Include/import" fields should be zero or more import statements, one 
per line. An import statement looks like: 

import com.verum.<DirName>.*;

where DirName is the name of the directory where the user defined classes are.

Note: 

●     FileName and DirName are strings containing only alphanumerical characters.

●     The ASD:Suite performs a series of syntax checks on the content of the "Include/import" fields 
and will report errors if syntax is incorrect.
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Generate stub code from an ASD interface model

The ASD:Suite provides the possibility of generating skeleton code that serves as a starting point for 
implementing handwritten code for a Foreign component. The skeleton stub code is compile-able 
such that an executable can be created. 

The main purpose of the generated stub code is to give you a head start in developing handwritten 
code, relieving you from the burden to write all the infrastructural code and clearly point out where 
you can add the custom user code.

To prevent that already existing handwritten files are overwritten accidentally, the following naming 
conventions are used for the various target language for which skeleton code can be generated: 

●     C++: <specified_component_name>Component.cpp_tmpl, 

●     C#: <specified_component_name>Component.cs_tmpl

●     C: <specified_component_name>Component.c_tmpl, 
<specified_component_name>ComponentImpl.h_tmpl

●     Java: ...\<specified_component_name>\impl\Component.java_tmpl

After the skeleton code is generated, rename the file(s) to the correct file name.

To initiate the stub code generation, select the "Tools->Generate Stub..." item. See following figure 
for a graphical representation:

Menu item to generate stub code

Note: 

●     The language properties (path, copyright, debug) specified in the interface model for code 
generation are reused to generate the stub code.

●     The stub code is generated only when the interface model is free from specification 
inconsistencies (conflicts)

To complete the stub code generation, fill in the missing information in the following dialog:
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you receive the following error: "Error: model cannot be reconciled 
automatically, please reconcile the model manually using the ASD:
Suite", i.e. there are "reconcile conflicts" in your design model, you have to reconcile the 
design model by following the instructions described in "Fix reconcile conflicts". 

Generate stub code for foreign components
The ASD:Commandline Client allows you to generate stub code for the implementation of an interface 
model by typing the following command in the command prompt:

asdc --generate-stub -v <code_generator_version> -l <language> -n 
<construction> -t <singleton/multiple> <interface-model>

The language can be 'cpp', 'csharp', 'c', 'tinyc' or 'java'. The construction denotes the 
specified construction parameters in the following format: component-name(construction-
parameters). The component-type denotes the type of the component, singleton or multiple, for 
which stub code is generated. The default for component-type is multiple.

Note: You will get the following error message: "Singleton stub cannot be generated 
for an interface with the SingleThreaded Execution Model. Use 
option "--component-type multiple" " when you specify singleton as 
component-type, the execution model of your model is SingleThreaded, and the specified 
language is not 'tinyc'. For details see "Specify execution model".

For more details on stub code generation see "Generate stub code for foreign components using the 
ASD:Suite" and for more details on the "--generate-stub" option of the ASD:Commandline Client type 
in the command prompt: asdc --generate-stub -h.

Download the ASD:Runtime
The ASD:Runtime software package for a desired target language can be obtained using the ASD:
Commandline Client by typing the following command in the command prompt:

asdc -r -v <code_generator_version> -l <language> -o <output-dir>

where, <code_generator_version> is the version of the ASD:Runtime you want to download, 
<language> is 'cpp', 'csharp', 'c', 'tinyc', or 'java', and <output-dir> is the path where you 
want the ASD:Runtime files to be downloaded.

For example: asdc -r -v 8.1.0 -l cpp -o X:\code\asd downloads the files of C++ ASD:
Runtime 8.1.0 into the "X:\code\asd" directory. 

Reconcile models
You can use the ASD:Commandline Client to perform design model reconciliation if there are no 
"reconcile conflicts" in your model (for details about reconcile conflicts see "Fix reconcile conflicts").

Design model reconciliation means update of the design model after changes in the related interface 
models without the need to open them in the ASD:Suite. Type in the command prompt the following 
command to reconcile your design model:

asdc --reconcile <modelfilename>.

Note: If the following error occurs: "Error: model cannot be reconciled 
automatically, please reconcile the model manually using the ASD:
Suite", follow the steps described in "Fix reconcile conflicts" to resolve the reconcile conflicts. 

Tips:
●     It is recommended to start the command prompt using the "Start->All Programs->ASD Suite 

Release 3 Vx.y.z->ASD Client Command Prompt" item, where x.y.z denotes a version number. 

●     If you want to specify a start-up folder for the ASD:Commandline Client started via the ASD 
Client Command Prompt, change line 11 in the "ASDPrompt.bat" file which you can find in the 
folder specified during installation. 

●     It is recommended to add the full path to the folder where the ASD:Suite is installed to the 
PATH environment variable . 

●     To ensure that the latest version of the ASD:Commandline Client is used whenever you call 
"asdc" in the DOS command prompt, remove from the PATH environment variable all 
references to folders where other versions were installed. 

●     Even though you can specify the server connection settings as part of the command in the 
command prompt, it is recommended to run the ASD:Suite desktop client once and save the 
connection settings, to store them as default values, also for the ASD:Commandline Client. 

For more details type asdc -h, or asdc --help in the command prompt.
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